Jump to content


Photo

microsoft visual c++ runtime 9.0 service pack 1 error


  • Please log in to reply
3 replies to this topic

#1 odigi

odigi

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 April 2009 - 10:18 PM

When trying to install I get the "Unable to install microsoft visual c++ runtime 9.0 service pack 1" error. The error was previously raisedin January by at least three other users and no worthwhile solution was provided.

For the record I run service pack 2 (like at least two of the folks mentioned) so the error is effectively suggesting a downgrade of a microsoft component ??

#2 GoddersUK

GoddersUK

    Valued Member/ Ad-Aware Beta Tester

  • Valued Member
  • PipPipPip
  • 688 posts

Posted 11 April 2009 - 10:56 PM

Hi,

I think it's unlikely that you run service pack 2 because, as far as I can tell, Microsoft has only ever released 1 service pack for Visual C++ 2008 (v9).

Please try and download this from here: http://www.microsoft...0d-3802b2af5fc2

Interestingly I only have Visual C++ 2005 (v8) installed on my machine, on which Ad-Aware works fine. If you're still having problems try installing that, available from here: http://www.microsoft...4d-389c36f85647

I'll check which version's installed on my other computer tomorrow if I remember.

Please let me know if this helps you solve the problem,

all the best - GoddersUK
If you are a paying user (Plus/Pro License) you should visit the Lavasoft Support Centre.

If you need help to remove an infection:

Read this first. Follow ALL the steps in it. If you do not then you will just be asked to go away and do so.
Then post your HJT log (copy and paste, don't attach) into a NEW topic in the HJT Log Forum
Await advice from either a Volunteer Security Advisor or a member of Lavasoft staff.


If you see anyone other than a VSA or Lavasoft staff member giving advice in the HijackThis forum please PM a mod.


DO NOT POST HJT LOGS IN ANY FORUM OTHER THAN THE OFFICIAL HJT LOG FORUM. We will be unable to deal with them there and will just tell you to go to the right place.


Please do NOT bump HijackThis log posts, it won't help you receive help any faster - the VSAs look for posts with zero replies. If after one week you have not received a response please repost your log file in a NEW thread.

#3 Dion

Dion

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 09 June 2009 - 03:11 PM

I fought with this problem for about two weeks. I started to epitomize Einstein's definition of insanity. I installed the downloaded runtimes from Microsoft, updated it (never actually needed the update), tried to install, cleaned the registry, tried to install, deleted the package from microsoft, tried to install, cleaned the registry, tried to install... Sometimes I rebooted sometimes not. Anyways none of that worked. I finally got the idea to try to install the package that was distributed with Ad-Aware.

Here are the steps I took. They're a little convoluted, but if you know a little about systems you should be able to get it from here. I'd be interested to see if this works for anyone else.

############

I started the Ad-Aware install program, and clicked through the options until the "Install" button was displayed.

Opened a cmd prompt (a browser window would do as well).

cd %TEMP%

I was able to identify that the Visual C++ runtime that you were installing was located in: "%TEMP%\mia*.tmp\date\Microsoft Visual C++ Runtime 9.0 (includes ATL and MFC) Service Pack 1\mFileBagIDE.dll\bag\vc_x86runtime.msi"

(The * is a number, you'll have to find it for yourself, in a cmd prompt you can use: dir /s/b vc_x86runtime.msi)

Change the directory containing the vc_x86runtime.msi

I ran "vc_x86runtime.msi" and when the prompted for a CD was displayed I browsed to the install directory and selected the vc_x86runtime.msi.

I followed the prompts and installed the package. When it was finished, I went back to the Ad-aware install window and continued with the installation as normal.

#########

The installation continued normally, and I'm a happy Ad-aware user again. :angry:

/Dion

#4 maurash

maurash

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 30 July 2009 - 06:46 AM

For those of you who are still getting this error, it is likely that you have the Windows Installer service disabled on your machine.

To fix this:

1. Go to "Start" -> "Run" , type "services.msc" and press on "Enter" button.

2. Double-click on the service named "Windows Installer".

3. Check the value in the "Startup type:" field. If it's currently set to "Disabled", then this is the
problem. Change it by selecting "Manual" from the drop-down box.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users